editlog - 現在との差分 (201401)

editlog - 現在との差分 (201401)


ページ名 MOD/Tool (閲覧)
投稿者ID WebMaster
投稿日 2014-01-02 (Thu) 17:22:28
差分情報 [ 差分 | 現在との差分 | ソース ]
現在との差分行 追加:115, 削除:15

*初めに [#l72dc95d]
 Modやセーブデータを弄る為のToolは多数リリースされています。各自の問題解決からMod開発まで、やりたい事に応じて選択してみてください。
尚、このページではゲーム外でスタンドアローンで利用するものを中心にまとめています

**目次 [#contents]
#contents

*総合 [#y9b75f0c]
**[[Construction Set>http://cs.elderscrolls.com/constwiki/index.php/The_Elder_Scrolls_Construction_Set]] [#z38f2850]
-公式謹製の開発toolです。Mod作成からちょこっとした改造までいろいろな事ができる奥が深いものです。
-Wiki内の解説ページ:[[MOD/Tool/ConstructionSet]]
-機能を拡張するOBSEプラグイン[[Construction Set Extender>OblivionScriptExtender#d61c0603]]なども。

**[[Nexus Mod Manager>http://www.tesnexus.com/content/modmanager/]] [#nexusmodmanager]
略称NMM。OblivionのMODダウンロードサイト[[TES NEXUS>http://www.tesnexus.com/]]と連動しており、TES NEXUSに公開されている、各ダウンロードサイトにある、 '''''DOWNLOAD WITH MANAGER''''' をクリックするとこのツールが起動し、即座に、予め指定しておいてディレクトリにダウンロードが始まります。ダウンロード後は、[[OBMM>MOD/Tool/OblivionModManager]]の影響を受けて開発されたツールのためか、OBMMとほぼ同じような使い方ができます。
**[[Mod Organizer>https://www.nexusmods.com/skyrim/mods/1334]] [#c7271b35]
略称MO。もともとはSkyrim用に作られたMod管理ツールだが、現在では、Oblivion や Fallout 3 でも使用できる。
C:\Program Files (x86)\Steam\steamapps\common\Oblivion 以下にMODファイルを配置するのではなく、Mod Organizer管理フォルダ以下にMODが配置され、仮想的にMODが反映されるのが大きな特徴である。

Mod Organizerからの、SteamのOblivionでOBSE起動する場合の手順は下記のとおりである。

+SteamからOblivionをインストールする。
+まず、Oblivionが正常に起動できることを確認する。
+OBSEv0021インストール
+Mod OrganizerをC:/pg/Mod Organizerにインストール。  
--Mod Organizer 2 はOblivionのOBSEに対応していないので、Mod Organizer 1.3.11をインストールする。
+Mod Organizerの設定→応急措置で、ロードメカニズムを「スクリプト拡張」に変更する。
+Mod Organizerの起動アプリケーションに下記を登録する。
--タイトル:SteamLaunchOblivionOBSE
--実行ファイル:C:\Program Files (x86)\Steam\Steam.exe
--開始フォルダ:C:\Program Files (x86)\Steam\steamapps\common\Oblivion
--引数:-applaunch 22330
+SteamLaunchOblivionOBSEを起動して正常にOblivionが起動できることを確認する。


↓ここから下はOBSEが正常にインストールできているか確認する手順です。
+Mod OrganizerでFOV Modifierをインストールする。
+SteamLaunchOblivionOBSEを起動する。
+FOV Modifierが正常に動作していれば、ゲーム起動時に左上に"FOV set to 90. To change that value type:Set CustomFOV to #"と表示される。

[Q&A]
-Q. 上記でOblivionを起動すると、CTDする。
-A. Windows自体のタスクトレイからSteamを落としたり、Windows自体を再起動したりしてみてください。こちらでもCTD発生しましたが、何度か試していると直りました。
-Q. omodのインストールができない。
-A. 下記手順でインストールしてください。
--OBMMをインストールする
--Mod OrganizerにOBMMを登録して、Mod OrganizerからOBMMを起動する。
--.omodファイルをあらかじめダウンロードしておく
--OBMMの「load」ボタンで、.omodファイルを読み込む
--OBMMのリストでMODを選択して、「Activate」を押下。omodインストール処理が実行されるので、指示にしたがってインストールする。

**[[Nexus Mod Manager>NexusOblivion:modmanager]] [#nexusmodmanager]
略称NMM。OblivionのMODダウンロードサイト[[TES NEXUS>Nexus:oblivion]]と連動しており、TES NEXUSに公開されている、各ダウンロードサイトにある、 '''''DOWNLOAD WITH MANAGER''''' をクリックするとこのツールが起動し、即座に、予め指定しておいてディレクトリにダウンロードが始まります。ダウンロード後は、[[OBMM>MOD/Tool/OblivionModManager]]の影響を受けて開発されたツールのためか、OBMMとほぼ同じような使い方ができます。

Skyrim、Fallout 3などにも対応しているため、起動時に、Skyrim、Oblivion、Nehrim、Fallout 3、New Vegasなどの、どのゲームのMODを管理するか問い合わせてきます。起動後に切り替えることもできます。
- MODのダウンロードとインストールがWindows Updateのように簡単になる。ワンクリックでダウンロード、ワンクリックでインストールが売り。
- 起動するたびに更新を確認するライブアップデート機能搭載。
- 一度に複数のMODを一括ダウンロード、ダンロードの一時停止/再開機能を持ったダウンロードマネージャを搭載。
- OBMMのように、複数のファイルから構成されるMODを1つのファイルにまとめることができます。
- [[OBMM>MOD/Tool/OblivionModManager]]に対応したomodファイルを読み込める機能もあるようです。
-2011年11月20日現在も開発が進んでいます。
-Wiki内の解説ページ:[[MOD/Tool/Nexus Mod Manager]]

**[[Oblivion Mod Manager>NexusOblivion:2097]] [#ldbe79d3]
-[[Forum>http://forums.bethsoft.com/index.php?showtopic=669394&hl=RELz]]
-通称OBMM(ObMM, OBM)。MODのロード順を編集したり、複数のファイルから構成されるMODを1つのファイルにまとめることができます。
-1つのファイルにまとめたファイルはomodという形式のファイルになり、Activate/Deactivateすることにより、ワンクリックでMODのインストールとアンインストールができるようになるので、MODの管理が大幅に楽になります。
-%%現在も活発に開発が進んでいます。%%2011年11月20日現在、2008年11月で更新が停止しています。今後は、OMODファイルと互換性がある代替ツールとして、[[Nexus Mod Manager>MOD/Tool/Nexus Mod Manager]]が役立つかもしれません。
-起動には.Net Framework 2.0以降が必要
-Wiki内の解説ページ:[[MOD/Tool/OblivionModManager]]

**[[Wrye Bash>NexusOblivion:22368]] [#m01735e4]
ModとSavefileを管理するツール。非常に多くの機能があります。
特に有用な機能としては以下のものがあります。
-Master Fileが足りないMODやセーブデータに対して不足しているMODが一目でわかる
-セーブデータの顔データやステータスを別のセーブデータへインポート&エクスポートする
-プラグインファイルに対してセーブデータから顔データをインポートする
-プレイ時間が225時間を超えた場合に発生することのある動作遅延バグの解消
-OOOやFranなど、NPCのレベルを変更するMODをゲーム途中のセーブデータに適用する
-'''''Bashed Patch'''''という導入済MODの競合データ統合及びゲーム設定変更プラグインを作成する
-自作魔法&自作エンチャント武具の名前変更や削除
-自作ポーションの名前・重量変更
-nVidia系ビデオカード使用時に発生するBlack Screen BugのMOD別修正
-セーブデータを掃除してファイルサイズを減らす
-Shivering Islesの致命的バグの修復(最新パッチを当てていれば不要です)
現在も活発に開発が進んでいます。
-Wiki内の解説ページ:[[MOD/Tool/WryeBash]]
*操作 [#ic1ad845]
操作は Mod Managerでも行なえるので敢えて導入する必要は無いかもしれません

**[[BSA Commander>NexusOblivion:3311]] [#hd5b26d0]
-bsa ファイルの解凍、作成を行うツールです。

**[[BSA UNPACKER>NexusOblivion:3117]] [#h084fbff]
-bsa ファイルを解凍するツールです。内のファイルの参照と並べ替え、個別抽出と全抽出をGUI形式で動作出来ます。Microsoft .NET Framework Version 1.1が必要。

*セーブデータ [#s260d123]
**[[ElderFaceLift >NexusOblivion:4600]] [#e9tt5gfe]
-プレイヤーキャラのフェイスデータを、セーブデータから別のセーブデータに移すことができるツール。
-フェイスデータのみをファイルに書き出したりは出来ません。
-Pythonを必要としないためにWrye Bashより導入が楽。操作法も簡単です。

**[[EssMod>http://www.4shared.com/file/253686306/ab7c7003/EssMod_v095.html]] [#x933678c]
-セーブ(ess)ファイルを書き換えて自キャラの種族・髪・目を指定したFormIDに書き換えます。
-自キャラのセーブファイルに他のセーブデータからFaceGenデータを Geometry Symmetric / Geometry Asymmetric / Texture symmetric 個別にインポートできます。&br;ちなみに Texture symmetric だけチェックしてインポートすると顔色のみインポートされ、顔色の修正が楽にできます。

**[[ Face Exchange Lite >NexusOblivion:7808]] [#y06d8d8c]
-上記のElderFaceLiftより確実に顔を移植できるツール。
-髪型・髪色・目の色を変更したり、フェイスデータを出力し保存することが可能。

**[[FaceGen to Oblivion Converter>http://speedy.sh/K92X4/FaceGen-to-Oblivion-Converter.rar]] [#l4207c2a]
[[紹介動画>http://youtu.be/d3MvT6TQKfQ]](Youtube)
-[[FaceGen Modeller>http://www.facegen.com]]のセーブファイル(*.fg)からOblivionのセーブデータに顔の造形や顔色をコピーするツール。
-以下、使い方を簡単に説明。
 1.コピーしたいFaceGen Modellerのセーブデータ(*.fg_)を選択。
 2.種族を選択。
 3.顔の造形と顔色のコピー方法を選択。左が顔の造形、右が顔色。それぞれ上から、
  『コピーしない / 種族の特徴の範囲内でコピー/ *.fgファイルデータの造形or顔色をそのまま強制コピー』。
 4.コピーするOblivionセーブデータ(*.ess)を選択。

**[[Focon>NexusOblivion:4158]] [#l2992e93]
-セーブデータ(*.ess)から[[FaceGen Modeller>http://www.facegen.com]]のセーブファイル(*.fg)に顔の造形や顔色をコピーするツール。

**[[INCREMENTAL SAVER >NexusOblivion:2937]] [#e1701627]
-タスクトレイに常駐するセーブ拡張ツール。クイックセーブやオートセーブをする度に、メニューからnew saveを選んだときのようにクイックセーブ1クイックセーブ2と新しくファイルが作られます。作るセーブの数の設定なども出来ます。

*Mod関連 [#t9a46cf4]
**[[FCOMhelper>NexusOblivion:16375]] [#djbu29ak]
-FCOMのesm,espのロード順を他の1,000以上のMODと共に自動で正しい順番に並べてくれます。

**[[Better Oblivion Sorting Software - BOSS>NexusOblivion:20516]] [#boss]
[[しとしん版対応のマスターリスト>http://jpmod.oblivion.z49.org/?%C7%C9%C0%B8%C8%C7Mod#j3de0220]]あり。
[[しとしん版対応のマスターリスト>OblivionOblivionJPModWiki:派生版Mod#j3de0220]]あり。
この項の記述はBOSS Version1.5(Stable)に関する記述です。
最新版(Version1.6以降)に関しては[[MOD/Tool/BOSS]]をご覧ください。

- 登録されているMODデータベースに基づいてMODのロード順を自動的に適切に変更してくれるツール。
-FCOMhelper が [[FCOM>MOD/総合#fcom]] を使用していなくても使えるように正式に対応したもの、略称BOSS。
-2009年12月4日現在のバージョン1.41では8,000以上のMODがデータベースに登録されています。
-使用方法は、解凍して出来たファイルをDATAフォルダの中に入れ、BOSS.BAT(EXEでは無いことに注意)を実行するだけ。
- ロード順の変更を行ってくれるほか、このプログラムを実行後に作成されるBOSS.logファイルには各MODに関するコンフリクト対策、同時に入れるべきではないMOD情報、CTD対策、推奨される代替MODなどのアドバイスや推奨されるBashed Tag名を教えてくれます。
-&color(#ff0000){''BOSSの masterlist.txt に入っていないMOD''};はロード順が後ろに回されます。よってそれらのMODは&color(#ff0000){''Dataフォルダのmasterlist.txt を自分で追加/修正する''};必要があります。後ろに回されたMOD名は、BOSS.logファイルで一番最後に表示されます。その情報をもとにmasterlist.txt を編集していきましょう。
- このツールはMODの名前ではなく、&color(red){''単純にesp/esmファイル名だけでMODを認識''};し、esp/esmファイルのロード順を変更するだけのものなので、 &color(red){''MOD の esp/esm ファイルは、インストールする時にファイル名を変更すると、 BOSS の masterlist.txt が認識してくれなくなります。''}; 認識してもらうには、esp/esmファイル名を正式なファイル名に戻すか、  masterlist.txt に登録されているesp/esmファイル名文字列を修正する必要があります。
- このツールは定期的に masterlist.txt ファイルが更新されています。新しいMODを導入するときはmasterlist.txt の更新がないか、BOSSを配布しているサイトを定期的にチェックしましょう。

**[[Mod Conflict Detector>NexusOblivion:2579]] [#b582c9d5]
-Dataフォルダ内のすべてのMODを走査し、競合するMOD同士を見つけます。競合するMODは、レポートに赤く表示されます。

**[[TES4Gecko>NexusOblivion:8665]] [#tes4gecko]
-主にMODのファイル自体への操作を行います。
-多彩な機能を持ちます
--複数のプラグインファイル(.esp)を結合してひとつにする"Merge Plugins"、
--プラグインファイル(.esp)をマスターファイル(.esm)に変換する"Convert to Master"、
--マスターファイル(.esm)をプラグインファイル(.esp)に変換する"Convert to Plugin"、等。
-Javaアプリケーションなので、もし、バージョンがJava 5(JRE 1.5)以上のものが、プリインストールされていなければ[[Java Runtime Environment(JRE)>http://java.com/download/index.jsp]]が必要です。
JREのバージョンのチェックは、([スタートメニュー]→[すべてのプログラム]→[アクセサリ]で見つかる)コマンドプロンプトで
 java -version
と入力すれば確認できます。以下のように、versionが1.5以上ならすでに動作に必要なバージョンはインストール済みです。
 C:\>java -version
 java version "1.6.0_16"
 Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
 Java HotSpot(TM) Client VM (build 14.2-b01, mixed mode, sharing)
1.5よりも前のバージョンの場合は、[[Java Runtime Environment(JRE)>http://java.com/download/index.jsp]]からダウンロードするか、([スタートメニュー]→[コントロールパネル]→[Java]を選んで「Javaコントロールパネル」を起動し[アップデート]タブをクリックして右下の[今すぐアップデート]をクリックしてアップデートしてください。あまりにも古いバージョンや100%Pure JavaでないMicrosoftの偽Java(MVMやVisual J++)のように、スマートアプデート機能が使えない場合があるので、上記の Sun Microsystems のJavaのサイトからJREをダウンロードしてください。セキュリティ、バグ、パフォーマンス改善の観点からもJREのアップデートを強く勧めます。

-※ TES4Geckoはバージョンアップして名前が変わりました。 [[旧 TES4 Plugin Utility>NexusOblivion:3083]]

-導入方法
--解凍してできたフォルダに入っている、TES4Gecko.jarファイルとmp3ファイル、LIPファイル(v15.1以降)のすべてを%%.exeがあるフォルダ%%任意のディレクトリに入れます%%(%%ここで初めてJREをインストールするとTES4Gecko.jarファイルが見えないことがあるので、その場合は%%一度Windowsを再起動して確認してみましょう。%%((jarファイルが見えない問題は、ただのファイルの関連付けや拡張子表示の問題です。))エクスプローラーのメニューの[ツール]→[フォルダオプション]を選択して[表示]タブをクリックして「詳細設定」で[ファイルとフォルダの表示]のラジオボタンが「すべてのファイルの拡張子を表示する」になっているかどうか確認してください。「登録されている拡張子は表示しない」がオフになっていることも確認してください。念のため「各フォルダの表示設定を保存する」のチェックもはずしておくといいでしょう。さらに、[ファイルの種類]タブをクリックして、JAR(Java ARchive : Executable Java File)ファイルの関連付けが適切に行われているかどうか確認してください。もし適切に行われていなければ、なんらかの理由でJavaのインストールがうまくいっていない可能性があります。再インストールを試みてください。

--TES4Geckoのショートカットの場所を正しい場所に変更し適応させます。
ここではTES4Gecko v1.5.2を例にとって説明します。
ショートカットを右クリックでプロパティを選び表示されるリンク先が
 \TES4Gecko.jar
となるべき部分と
作業フォルダ
 
となるべき所が
リンク先
 C:\WINDOWS\system32\javaw.exe -Xmx1200m -jar "C:\Tmp\TES4Gecko.jar"
作業フォルダ
 C:\Tmp
になっているのでc:\Tmpの箇所をTEST4Geckoインストールディレクトリに変更してください。
javaw.exeのパスもJavaをインストールした、javaw.exeがあるディレクトリでに変更してください。
例1(JDK : Java Development Kitをインストールしている場合):
 C:\Program Files\Java\jdk1.6.0_16\jre\bin\javaw.exe -Xmx1200m -jar "\TES4Gecko.jar"
例2(JRE : Java Runtime Environmentのみをインストールしている場合):
 C:\Program Files\Java\jre1.6.0_02\bin\javaw.exe -Xmx1200m -jar "\TES4Gecko.jar"

- ショートカットの &color(red){''-Xmx1200m''};は&color(red){''最大ヒープメモリサイズを1200MB''};確保することを意味します。メモリをそれだけ積んでいないと意味がないということですが、メモリを沢山積んでいるからといって最大ヒープメモリサイズをやたらと大きくすると、こんどはJavaプログラムでガベージコレクション(GC)が発動したときに、メモリを清掃してJavaの作業領域を増やすために破棄されたオブジェクトを解放することがあるために、環境によっては、そのときだけものすごく負荷がかかります。C言語のfree()関数、C++のdelete()メンバ関数に相当する挙動を、指定された最大ヒープメモリサイズになるまで実行しないことがあるといことです。Javaは年々、バージョンが上がるにつれてこれらのパフォーマンスを改善していますが、古いバージョンのJavaを使用しているときは注意してください。Oblivionをプレイしている人はメモリを沢山積んでいるのでほとんど気にすることはないとは思いますが、&color(red){''最大ヒープメモリサイズは多くてもメモリ容量全体の半分程度};までを推奨します。

- 任意の場所に上記のように修正したTES4Geckoのショートカットを置き、クリックするとTES4Geckoが立ち上がるようになります。また、JAR(Java ARchive : Executable Java File)ファイルの関連付けが適切に行われていれば、TES4Gecko.jarファイルを直接クリックしても立ち上がります。しかし、JARファイルを起動するときに最大ヒープメモリサイズが設定されないのでパフォーマンス改善のために上記のショートカットを設定したほうがいいでしょう。Javaで&color(red){''デフォルトの最大ヒープメモリサイズは64MB''};と非常に少ない値でパフォーマンスに限界があります。
**[[TES4Edit>NexusOblivion:11536]] [#tes4edit]
-Mod同士のdataを比較することができます。特にどのmodがどの部分を上書きしてるか詳しくわかります。たとえば[[このSS>http://www.tesnexus.com/downloads/images/11536-1-1195873505.jpg]]を見てください。
Xivilaiの様々なdataをどのModが上書きしているのか分かります。
-Mod同士のdataを比較することができます。特にどのmodがどの部分を上書きしてるか詳しくわかります。
またHide no conflict rows機能を使うと競合しているdataだけを表示し、重複している箇所を非表示にできるので、
競合を確認する場合は非常に便利です。
--見れるだけでなくそのまま編集を行うことができます。この編集機能は特に日本語化の時に役に立ちます。
例 [[日本語化済みのUOPのdataを他のmodに移植する場合>http://shy.jsphr.net/upload/img/ups32115.jpg]]
&br;
-コンソールで使うFromIDを確認する際にも使えます。FromID自体はCSでも確認できますが、
その場合FromIDの先頭二桁の数字をObMMで確認しなければいけません。それがTES4Editを使えばこれ一つで済みます。
FromIDを参照する場合Launcherでチェックを入れているModはTES4Editでも読みこむようにしてください。
FromIDの先頭二桁の数字は読み込まれたModの数によって変動します。
&br;
-Modの中のVanillaと同一のdataを削除する機能もあります。
Googleで「TES4Edit クリーニング」と検索してみてください。詳しく解説しているブログが見つかるかもしれません。Wiki内の[[MOD/特集記事/クリーニング]]も参照してみてください。

またクリーニングが推奨されるmodについては[[TES4Edit Cleaning Guide>CSWiki:TES4Edit_Cleaning_Guide#List_of_Mods_Needing_Cleaning]]のページから確認できますが、
この中から所持しているMODを探すのは大変です。
ver1.6以降の[[BOSS>MOD/Tool/BOSS]]を使えば対象modのNote欄にNeeds TES4Edit cleaningと表示されるので、こちらから調べる方が楽です。
&br;
-ModからMaster指定を削除するClean Mastersという機能もあります。ModにMasterの指定先と関連のあるdataがない場合削除できます。
誤ってMaster指定してしまった場合はこの機能で削除してください。
Master関連には他にもMaster指定を加えるAdd Masters、Master指定の並び順を整理するSort Mastersなどがあります。
**[[TES4Files>NexusOblivion:8489]] [#tes4files]
-Mod に使用されているファイルの抽出や bsa ファイルの作成などに。
-Mod の esp ファイルを指定すると、それに必要な mesh, textures, sound ファイルなどを抽出し、TES4Files を起動した場所にフォルダを作成してコピーする。
--BSA:  bsa ファイルを作成。(NoCOMP もあわせてチェックすると非圧縮 bsa になる。)
--FixNIF: NIF ファイルの Texture Path に Foward Slash が使用されていれば、Back Slash に修正する。

-[[最新版>http://straygenius.com/index.php?title=TES4Files]] は、作者のサイトにあります。エクスポート終了後がかっこよくなったりしています。
** [[BAIN Wizard Installation Project>NexusOblivion:37230]] [#bainwizardinstallationproject]
[[OBMM>MOD/Tool/OblivionModManager]]にしか対応していないMODや[[BAIN>MOD/Tool/BAIN]]に対応していないMODのいくつかをBAINに対応させようとBAIN-friendlyなディレクトリ構成のアーカイブを用意しています。
Wizard.txtがすでに用意されているのが特徴です。

BCF(BAIN Conversion File)ではないため、BAINへの変換は手動で行う必要があり、2011年12月3日現在、まだ6つのMODしか用意されていませんが、有名なMODはこれでBAINに変換できます。

** [[BAIN Wizard Converter>http://l2tsubaki.wordpress.com/tag/bain-wizard-converter/]] [#bainwizardconverter]
[[Version 0.2.2>http://l2tsubaki.wordpress.com/2011/09/17/wip-bain-wizard-converter-v0-2-2/]]

[[OBMM>MOD/Tool/OblivionModManager]]のscript.txtを使ったインストーラーにしか対応していないMODのうち、script.txtを[[BAIN>MOD/Tool/BAIN]]のWizard.txtに変換し、BAINのウィザード形式のインストーラーに対応させることができるツールです。
ただし、2011年12月3日現在、
- 圧縮ファイルを変換して新しい圧縮ファイルを生成してくれる機能はなく、解凍してディレクトリを展開した状態のものしか変換できないので、圧縮・解凍は自前で実行する必要があります
- ディレクトリ構成まではBAIN-friendlyには完全には変換してくれないので注意が必要です。
- 一部のMODは変換するためにマッピングファイルが必要になります。
- OBMMのscript.txtスクリプト固有の文法で、BAINのWizard.txtには存在しない文法がある場合は、このツールで変換することができません。
- Options の Check the versions (Oblivionのバージョンをチェックするスクリプトを追加する)が正しく機能しないことがあります。問題が起きたときは Check the versions を無効にしてください。
** [[BAIN Conversion Files (TESCOSI の BAIN作成方法を解説しているWikiより)>http://tesposi.animolious.com/wiki/Oblivion:Complete_Installation_Guide/Part_2/BAIN/Create_BAIN-Friendly_Packages]] [#j5fea3f3]
有名所のMODを押さえた BCF (BAIN Conversion Files) をダウンロードできる[[TESCOSI>http://tesposi.animolious.com/wiki/]]のBAINの作成方法を解説しているページの一部です。

いくつかのMODを[[OBMM>MOD/Tool/OblivionModManager]]から[[BAIN>MOD/Tool/BAIN]]に鞍替えしたい人に役立つかもしれないサイトです。

このページから有名なMODのBCFをいくらかダウンロードできます。
ここにあるBCFを使えばscript.txtを Wizard.txt に変換しなくても簡単にインストールできるBAINフレンドリーなパッケージを[[OMOD形式>MOD/Tool/OblivionModManager]]から変換できます。BAINに変換することでスクリプトがなくなりウィザード形式でインストールできなくなるものがありますが、BAINパッケージの構造上、基本は、わざわざウィザードを使わなくても簡単にインストールできるものばかりです。

BCF (BAIN Conversion Files) の使い方は[[BCF (BAIN Conversion File) の使い方>MOD/Tool/BAIN#howtousebcf]]を参照してください。
*.ini操作 [#s3795d01]
**[[ INI Tweaker>NexusOblivion:1937]] [#j83378ea]
-.ini の値を調整するツールです。チェックボックス式ですのでクリックするだけで簡単に調整できます。バックアップ機能付き。Tweakより簡単に設定したい人向け。

**[[Tweak>NexusOblivion:2780]] [#b54a64a9]
-レジストリエディタのような見た目の .ini ファイルエディタです。英文の解説を見ながら値を調整することができます。 INI Tweakerより詳細に設定したい人向け。多世代バックアップ機能付き。

*その他 [#jfa2741f]
**[[espexport>http://cid-28a0dafa9c54f803.skydrive.live.com/browse.aspx/.Public]] [#s7834bf7]
esm, esp ファイルに登録されているテキストデータを(CS のエクスポートデータ準拠で)出力するツール。
変更点(ファイルに登録されたデータ)だけを出力してくれるので、翻訳データの作成に便利。
OBSE の messageEx も出力してくれる。

**[[Font Generator>NexusOblivion:2331]] [#s32c579b]
-[[Forum>http://www.elderscrolls.com/forums/index.php?showtopic=338543]]
-Windowsのフォントからのフォントを制作するツールです。これで日本語化が進む?

**[[Profile Manager>http://planetelderscrolls.gamespy.com/View.php?view=Utilities.Detail&id=6?]] [#u06d4d78]
-ユーザープロフィールを選択してを起動できるようにします。
-簡単に複数の.iniやセーブファイルフォルダを使い分けることができます。
-VisualBasic6のランタイムが必要のようです

**[[TES4LODGen>NexusOblivion:15781]] [#tes4lodgen]
-全てのアクティブなプラグイン・ファイルから情報を読み込み、DistantLOD(Vanillaだと近距離以外では表示されない構造物などの遠景用データ)を自動作成するツール。
- インストール不要。アーカイブを伸長してTES4LODGen.exeを実行するだけで実行完了。Oblivionをインストールしているディレクトリを自動的に検出する。
-生成されたデータはOblivion\Data\DistantLODフォルダに保存されます。
-[[devnull.devakm - Other Improvements:>http://devnull.devakm.googlepages.com/other]]のDISTANT OBJECTSも参考にどうぞ。
最新バージョン:[[3.032EXP>NexusOblivion:15781]] [2014/5/30]

-''Mod概要''
全てのアクティブなプラグイン・ファイルから情報を読み込み、&color(blue){DistantLOD(Vanillaだと近距離以外では表示されない構造物などの遠景用データ)を自動生成する};ツール。
 
-''インストールと諸注意''
インストールは不要で、ダウンロードしたアーカイブを解凍し、TES4LODGen.exeを実行するだけで動作します。
(Oblivionをインストールしているディレクトリを自動的に検出します。)
TES4LODGenが生成したデータは&color(blue){Oblivion\Data\DistantLOD};に保存されます。
[[devnull.devakm - Other Improvements:>http://devnull.devakm.googlepages.com/other]]のDISTANT OBJECTSも参考にどうぞ。
*** 注意事項 [#gb83ad5d]
&color(red){''※LODGenを使用すると環境によっては遠景の樹木が浮いてしまう事もあるようです。''};

新しい建物を追加するMODを導入し、その建物が遠景でも見えるようにしたい場合は、再度このEXEファイルを実行する必要があります。そのさい、以前生成したDistantLODのファイルの上書き確認が出ますが、気にせずにすべてYesを選択して上書きしてください。

**[[Landscape LOD generator tes4ll>NexusOblivion:40549]] [#z6f20d74]
-全てのアクティブなプラグイン・ファイルから情報を読み込み、遠景データを最適化して近景に近い見た目にするツール。&br();角張ったVanillaの遠景がなめらかになります。
-一見TES4LODGenの類似ツールですが、こちらはOblivion\Data\meshes\Landscape\LODに保存される遠景データを最適化するため、TES4LODGenのようにDistantLODのデータ(Vanillaでは表示されない遠景構造物)は生成されません。
-解凍したデータは全てOblivion\Data\に入れて使用します。大事なデータのバックアップは忘れずに。
-ツールの実行はtes4ll_midres.bat tes4ll_highres.bat tes4ll_ultimate.batのいずれかから行います。&br();とにかく最高に綺麗にしたい場合はultimate、とにかくパフォーマンス重視ならmidresを選んでください。&br();MODデータ量にもよりますが、作業は数分かかります。
-tes4ll_normalmaps.batはノーマルマップを、tes4ll_tes4qlod.batはカラーマップを生成するツールです。&br();よく分からない内は実行しない方がいいでしょう。
**[[Landscape LOD generator tes4ll>NexusOblivion:40549]] [#tes4ll]
最新バージョン:[[5.01>NexusOblivion:40549]] [2015/2/3]

-''Mod概要''
全てのアクティブなプラグイン・ファイルから情報を読み込み、遠景データを最適化して近景に近い見た目にするツール。
角張ったVanillaの遠景がなめらかになります。
一見[[TES4LODGen>MOD/Tool#tes4lodgen]]の類似ツールですが、こちらは&color(blue){Oblivion\Data\meshes\Landscape\LODに保存される遠景データを最適化します};。
そのため[[TES4LODGen>MOD/Tool#tes4lodgen]]のように&color(red){DistantLODのデータ(Vanillaでは表示されない遠景構造物)は生成されません};。
Textureの生成では、付属のS3TC他、[[nconvert>http://www.xnview.com/en/]]や[[nvdxt>https://developer.nvidia.com/legacy-texture-tools]]も使えます。
 
-''インストールと諸注意''
解凍したデータは全て&color(blue){Oblivion\Data\};に入れて使用します。
既に存在するデータは基本的に上書きしますので、大事なデータのバックアップは忘れずに。
 
--''LOD Meshesの作成''
作成ファイル:&color(blue){Data\meshes\Landscape\LOD\};
tes4ll_midres.bat、tes4ll_highres.bat、tes4ll_ultimate.batのいずれかから行います。
とにかく最高に綺麗にしたい場合はultimate、とにかくパフォーマンス重視ならmidresを選んでください。
midres、highres、ultimateの順にゲーム内描画負荷が上がります。
MODデータ量にもよりますが、作業は数分かかります。
 
--''LOD Texturesの作成''
作成ファイル:&color(blue){Data\Textures\landscapelod\generated\};
tes4ll_normalmaps.batはノーマルマップを、tes4ll_tes4qlod.batはカラーマップを生成するツールです。
tes4qlodには解像度のオプションがあります。
>tes4ll_tes4qlod.batを右クリックし編集を選び、エディタ(メモ帳など)を起動し以下の通り書き換えます。
-1024x1024(デフォルト)
tes4ll -t -b ini\tes4ll\tes4ll_all.mpb -f "tes4qlod,qlod&color(red){1};,option_blending,overwritelods" 
-2048x2048
tes4ll -t -b ini\tes4ll\tes4ll_all.mpb -f "tes4qlod,qlod&color(red){2};,option_blending,overwritelods" 
-4096x4096 &color(gray){※編者(i7 920:4.2GHz)は20minかかりました};
tes4ll -t -b ini\tes4ll\tes4ll_all.mpb -f "tes4qlod,qlod&color(red){4};,option_blending,overwritelods"

--ver5.01からは記述が以下のように変わっています。
>tes4ll tes4qlod qlod1 option_blending overwritelods logfile=tes4qlod.log ini\tes4ll\tes4ll_all.mpb

***[[Multi Purpose GUI>NexusOblivion:41447]] [#mpgui]
最新バージョン:[[1.22>NexusOblivion:41447]] [2012/08/02]

-''Tool概要''
[[tes4ll>MOD/Tool#tes4ll]]の作者によるGUIインターフェースです。
[[tes4ll>MOD/Tool#tes4ll]]他、[[TES4qLOD>NexusOblivion:42473]]や[[TESAnnwyn>http://www.oceanlightwave.com/morrowind/TESAnnwyn.html]]にも対応します。
上記bat操作と行うことは変わりませんが、GUIからオプションを設定できるのはメリットのように思います。
 
-''インストールと諸注意''
Setupファイルを実行し、任意の場所にインストールしてください。
(基本的にインストールしたファイル(mpgui.exe)は直接起動させることはありません)
 
-''Multi Purpose GUIでのtes4ll操作''
&color(blue){Data\Ini\tes4ll\tes4ll_all.mpb};から実行します。
まず&color(blue){Plugins};タブでESPファイルを指定し、&color(blue){Worldspace};タブで&color(blue){Read};してください。
読み込んだ&color(blue){Worldspace};から作成したい対象を選択します。
(※おそらく何も変えなければTamrielが選ばれているはずです)
続いて&color(blue){LOD Meshes};、&color(blue){Normal Maps};、&color(blue){Color Maps};の設定をそれぞれのタブにて行います。
&color(blue){Make ~~ チェックボックス};をチェックすることで有効(=作成する)になります。
解像度などのオプションは任意に設定してください。
そして&color(blue){Start Process};タブにて実行オプションを設定し、&color(blue){Click me if you are ready};ボタンを押せば作成開始されます。
※&color(blue){Overwrite the original files};オプションを切ると、作成したファイルが規定ディレクトリに移されず&color(blue){Data};にダラーっと作成されます。
 
--&color(gray){ある編者余談};
&color(gray){LOD Textureを吟味されている方には、Meshesの作成がメインのようにも思います。};
&color(gray){無論環境によりますが、競合ファイルは[[Optimised Distant Land MAX>MOD/パフォーマンス#si37b8as]]や[[UOP>MOD/BugFix#uopseries]]、一部のリテクスチャMODなどが該当します。};
&color(gray){調子にのってUltimateで作成してみましたが、思ったほどFPSは落ちませんでした。};
&color(gray){喫水線が滑らかで素敵です。};
&color(gray){Normal MapのFake Shadowオプションは他のLODテクスチャには無い演出で、中々に独特でした。};
&color(gray){調子にのってnvdxtを使い2048無圧縮ファイルを作ってみましたが、1ファイル20Mを超えますので作成時間などなどご注意されたし…。};



トップ   新規 一覧 検索 最終更新   ヘルプ   最終更新のRSS